PowerShellでスクリプトが実行できないとき
create: 4/14/2020
PowerShell

PowerShell に posh-gitをインストールしたところ、以下のようなエラーが発生しました。

> ./install.ps1
このシステムではスクリプトの実行が無効になっているため、ファイル C:\develop\apps\posh-git\install.ps1 
を読み込むことができません。詳細については、
「about_Execution_Policies」(https://go.microsoft.com/fwlink/?LinkID=135170) を参照してください。

どうやらダウンロードした.ps1ファイルを実行する権限がない様子。

実行権限を与える

PowerShell を管理者権限で起動します。

Set-ExecutionPolicy RemoteSigned

管理者権限じゃないとおんなじエラーが発生します。