xcodebuildができなくなって困った
create: 2018-9-28
node.js xcode

xml2json入れようとしたらエラーが出た。

あれ〜〜?

yarn add xml2json

〜〜 中略 〜〜
〜〜 'xcodebuild' requires Xcode 〜〜

詳しいエラーはキャプチャしてませんでした。すみません。

xcode-selectをコマンドラインツールズからXcodeに変更

エラーメッセージを見るとXcode本体をみてねとのことだったので変更。

sudo xcode-select --switch /Applications/Xcode.app

ライセンス承諾

さらにちゃんと利用規約読めとのことだったので

sudo xcodebuild -license

読みすすめてagreeする。
これでやっとインストールできました。